Status of the Samba 4.0 integration in Zentyal 3.0

As you may already know, when we started the Zentyal 2.3 development, we took the decision of integrating Samba4, which was about to enter the beta phase. This sounded risky and was questioned by some, but as we have the ambitious goal of being a full Active Directory replacement, and improve the migration processes from Windows server environments we decided to go for Samba4 integration and we do not regret it.

During the whole year Samba4 has been evolving really fast and we were confident that at some point around the release date of Zentyal 3.0, or not too late, there would be a final Samba 4.0 stable version solving the problems of the first beta versions. We can also say that during this development we have tried to contribute as much as possible with the Samba team, by giving feedback, coding and sending patches.

The thing is that Samba 4.0 stable has been released already and sadly, as you can see in the official announcement, it has been released still with known issues that affect some scenarios that Zentyal aims to provide.

So, how to solve this situation in these scenarios? To start with, we have written a brief list of the current known issues. In the next days we are going to detail them, provide as much documentation as possible about the different scenarios, what works and what doesn’t, and what can be done, including best practices for deployments. The documentation will be ready during next week. We also plan to implement more checks in the Zentyal Samba module to avoid common configuration mistakes, and add the possibility to recover from them, for example, allowing easy reconfiguration if Samba has been provisioned with a wrong domain name.

We can assure you that we will keep working hard making Zentyal a full Active Directory replacement and you should expect clear information about the current issues and the updates on the zentyal-samba packages.

Thanks for using Zentyal and keep the feedback coming so that we can all make it the best Linux alternative to Windows Server!



3 Responses to “Status of the Samba 4.0 integration in Zentyal 3.0”

  1.   Andrey Says:

    When you plan to upgrade to samba zentyal?

  2.   jacalvo Says:

    You mean packaging Samba 4.0.0? We’ve already done it, it’s available in the experimental PPA:

    https://launchpad.net/~zentyal/+archive/experimental/+packages

    It will be published to the official repo today or tomorrow.

  3.   J. A. Calvo Says:

    More detailed documentation about some Zentyal scenarios with Samba4 can be now found at http://trac.zentyal.org/wiki/Documentation/Community/Development/SambaScenario

Leave a Reply